Inicio > Informática > WPA y WPA2 en eeepc 901 con Ubuntu 10.04 Lucid Lynx

WPA y WPA2 en eeepc 901 con Ubuntu 10.04 Lucid Lynx


Con los pocos días que tengo instalado Lucid Lynx, y ya es el segundo problema con que me encuentro en la nueva distribución de Ubuntu para Netbooks. Lo peor de todo es que con cada actualización surgen nuevos problemas… Aunque no es algo exclusivo de Ubuntu; en Windows suele ocurrir lo mismo.

El caso es que en casa uso seguridad WPA para conectarme a la red inalámbrica, y no consigo conectarme con el nuevo Ubuntu 10.04 desde mi eeepc901. Por lo visto, es un problema con los drivers que se solventa con el núcleo 2.6.33, pero esta distribución aún usa el 2.6.22. Lo más curioso es que con WPA2 Enterprise si funciona.

Hay dos soluciones posibles:

  1. En tu punto de acceso o router, fuerza el uso de WPA2+AES. En mi router (un SMC) por defecto se usa el modo mixto WPA/WPA2. Para mí funcionó a la perfección, jodiendo a mi novia que ya no podía conectarse desde su portátil con Windows XP :S
  2. Compila tus propios controladores. En este foro viene una explicación muy completa, que yo reproduzco a continuación:

Descarga los controladores de  http://www.ralinktech.com/ “RT2860PCI/mPCI/CB/PCIe(RT2760/RT2790/RT2860/RT2890)“ dated 01/29/2010, version 2.3.0.0

Descomprime, entra en el directorio y edita el siguiente fichero os/linux/config.mk y cambia las siguientes líneas:

HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

Edita el fichero common/cmm_wpa.c y busca y reemplaza MIX_CIPHER_NOTUSE por WPA_TKIPAES_WPA2_TKIPAES.

A continuación, debes hacer lo siguiente:


# Compilar e instalar el módulo
sudo make && sudo make install

# Quitar el módulo anterior
sudo ifconfig wlan0 down
sudo rmmod rt2860sta

# Guarda copia del módulo anterior por si las moscas
sudo mv /lib/modules/2.6.32-22-generic/kernel/drivers/staging/rt2860/rt2860sta.ko rt2860sta.ko.dist
# Copia el nuevo módulo a su lugar de destino
sudo cp rt2860sta.ko /lib/modules/2.6.32-22-generic/kernel/drivers/staging/rt2860/

# Instala el nuevo módulo
sudo depmod -a sudo modprobe rt2860sta
# Por en marcha la interfaz wifi
sudo ifconfig ra0 up

Si todo ha ido bien, ya debéis tener wifi con WPA personal funcionando sin problemas.

Categorías:Informática Etiquetas: , , , ,
  1. Artur
    marzo 27, 2011 a las 8:57 pm

    Muy buenas, soy nuevo nuevisimo en ubuntu, acabo de instalar la version 10.10, el problema se encuentra en que mi tarjeta es la RT2860 y he tratado de seguir primeramente los pasos de esta página: http://ubuntuforums.org/showthread.php?t=1476007 y seguidamente encontre la tuya pero nada de nada, no hay manera, otra cosa esque al meterme en la pagina para comprobar el kernel para hacer los pasosnecesarios, hay dos carpetas, una con nombre 3.6.35-22-genereic y 3.6.35-28-generic, ¿tendria que utilizar este segundo no? muchas gracias por tu tiempo, un saludo.

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s